Upgrading Calico for Kubernetes

Before you begin

  • You must first upgrade to at least Calico v2.6.5 before you can upgrade to Calico v3.4.0.

    Important: Calico v2.6.5 was a special transitional release that included changes to enable upgrade to Calico v3.x. Do not skip this step!

  • If you are using the etcd datastore, upgrade etcd to the latest stable v3 release.

About upgrading to Calico v3.4.0

The steps to upgrade differ according to your current version and datastore type.